Not-so-emergency: Indicators and hazards not working (Fixed)

View previous topic View next topic Go down

Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Little Black Van on Thu Dec 20, 2012 10:51 am

Hey guys, got a problem. Stuck in Holland right now with a ferry booked in Dunkirk and none of my indicators or my hazards are working. Any ideas what this could be?


Last edited by Little Black Van on Fri Dec 21, 2012 10:29 pm; edited 1 time in total

Little Black Van
Centurion

Posts : 230
Join date : 2012-03-23

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by HighlyJetted on Thu Dec 20, 2012 11:50 am

Indicator relay? Under the dash, black box with 3 connectors that plugs into the fuse box.

Otherwise one of the fuses.
avatar
HighlyJetted
Hijet Overdose

Posts : 5410
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by HighlyJetted on Thu Dec 20, 2012 11:51 am

Try tapping that relay with a screw driver.

also mess with the hazard warning switch a bit as this can stop them all working if its dodgy.
avatar
HighlyJetted
Hijet Overdose

Posts : 5410
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Logi on Thu Dec 20, 2012 2:13 pm



santa
avatar
Logi
Jet Warrior

Posts : 3576
Join date : 2011-04-07
Age : 81
Location : Kilmarnock

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Logi on Thu Dec 20, 2012 2:14 pm

Prob hazard switch.
avatar
Logi
Jet Warrior

Posts : 3576
Join date : 2011-04-07
Age : 81
Location : Kilmarnock

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Little Black Van on Fri Dec 21, 2012 10:45 am

Yep, drove to Dunkirk using hand signals, Now at a friend's place and got the relay in my lap, just testing it to see if it is at fault. If not, what is this about the hazard switch that can cause problems?

Little Black Van
Centurion

Posts : 230
Join date : 2012-03-23

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by HighlyJetted on Fri Dec 21, 2012 12:05 pm




The system works like this:-

While the ignition key is off, if you press the hazard switch, it moves the last lever of the 4 lever hazard switch so that it takes the indicator power feed from the horn/brakelight fuse which is always on.

Under normal conditions with the hazards off, the system takes its feed from the wiper/turn fuse.

To detect if it is the indicator relay at fault put a wire across the spade terminals of the switched part of the flasher relay like this green line.



To work out which is which test the socket for:-

Red plus is the feed from battery - 12v when measured with black probe on the chassis some where clean.
Ground - you should get continuity (e.g. 0.02 ohms or something tiny like that) with the black probe on the chassis with indicators off.
* (black star) you should get no continuity with the black probe on ground if the indicators are off, then if you turn left or right then there will be continuity.

p.s. if you cant find that 12 volt feed, its either the fuses or that damn harard warning light swtich!!


Last edited by HighlyJetted on Fri Dec 21, 2012 12:10 pm; edited 1 time in total
avatar
HighlyJetted
Hijet Overdose

Posts : 5410
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by HighlyJetted on Fri Dec 21, 2012 12:07 pm

p.s I have a spare flasher relay in front of me which I can put in first class recorded post tomorrow if you need one.
avatar
HighlyJetted
Hijet Overdose

Posts : 5410
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Little Black Van on Fri Dec 21, 2012 10:28 pm

Discovered the problem, and it was so simple. I tested the relay and it appeared to be fine, so I put it back in and wiggled it while putting the indicators on, and heard the noise you get with shorting electrical connections, so had an idea. A minute later, by bending the prongs out slightly with a pair of pliers, I fitted it back in and it worked perfectly. Merely the female spades in the fuse box getting a bit worn. To be honest, I should have known, since I've had the same problem on a headlamp bulb and washer pump on this van, but in my panic and stress, I didn't.

Thank you all very much for your help and suggestions guys, all I need to do now is do a more permanent fix on my passenger door mirror, the mounting bracket around the ball disintegrated inside and it nearly fell off. It's currently wedged in place with two 1 euro cent coins, some white gaffa and two little wedges we cut from a spare bit of ash I had in the back. XD

Little Black Van
Centurion

Posts : 230
Join date : 2012-03-23

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by HighlyJetted on Sat Dec 22, 2012 1:17 am

If you know where you want it, cover the ball in grip fill then adjust it to the right place and let the glue set?!
avatar
HighlyJetted
Hijet Overdose

Posts : 5410
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Little Black Van on Sat Dec 22, 2012 11:34 am

It's not the ball, but the little peg that comes off it into the mounting bracket. The ball itself is fine.

Little Black Van
Centurion

Posts : 230
Join date : 2012-03-23

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Logi on Sat Dec 22, 2012 11:40 am

Mines was the wee adjusting screw was seized, broke the bit inside trying to free it, i put some gaffa tape over the hole in the bottom and pumped the glue gun in the wee hole for the screw till it filled up. Not perfect but holds it ok.
avatar
Logi
Jet Warrior

Posts : 3576
Join date : 2011-04-07
Age : 81
Location : Kilmarnock

Back to top Go down

Re: Not-so-emergency: Indicators and hazards not working (Fixed)

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum