engine light flashed on and no start! help!!

View previous topic View next topic Go down

engine light flashed on and no start! help!!

Post by streetboy on Sat Jun 29, 2013 5:56 pm

Hi all, today the engine light came on and went off again on my way to work. Seemed like a little stutter but very very slight. Then stopped at some lights and it went dead Shocked 
Despite winding it over it would not start. It was a little low on fuel so hiked it to the garage up the road, came back and whacked it in. Started practically first time. Neutral made it fine to work but as I drew in the light came on and off again and then it cut out again.
I did notice the oil level was pretty low and topped it up. Left it an hour and it started first time. On the way home no dramas but the light did flash on and off again but I got home some 15 miles without cutting out.

So two questions.......... I found the ecu on the passengers side and the only plug I can see is a three pin plug, brown, green/white and brown/white, is this the diagnostic plug? (993 efi)

And does anyone know what the problem might be? possibly a blocked fuel filter causing a drop in fuel pressure and causing a little stumble/

Any help gratefully received. Wink 

streetboy
Chatterbox

Posts : 62
Join date : 2012-02-17

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by rich the mechanic on Sun Jun 30, 2013 7:13 pm

it could be many things but the three pin plug short the two terminals out at the bottom and turn the ignition on and count the flashes it should shed a bit of light for you.
avatar
rich the mechanic
Jet Addict

Posts : 1824
Join date : 2010-01-03
Age : 37
Location : Essex

http://www.thread-bare.biz

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by streetboy on Mon Jul 01, 2013 6:16 am

Thanks for that. cant see any other plug near the ecu so must be it.
Its run fine over the weekend but if its done it once.........
I'll run a check.

streetboy
Chatterbox

Posts : 62
Join date : 2012-02-17

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by streetboy on Sat Jul 06, 2013 6:14 pm

well its been fine all week, didn't use it Friday and popped down the road today and on the light came, bit of a stumble, pulled up at home and it cut out.

Bridged the ecu wires and it read two fault codes, 42 coolant temp open or shorted? and 52 vehicle speed sensor open or shorted?

Anyone any ideas what could be wrong and how to fix it?

Many thanks, Mark.

streetboy
Chatterbox

Posts : 62
Join date : 2012-02-17

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by Logi on Sat Jul 06, 2013 6:22 pm

Throttle position sensor? Mine was very hesitant, light came on?
avatar
Logi
Jet Warrior

Posts : 3603
Join date : 2011-04-07
Age : 82
Location : Kilmarnock

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by streetboy on Sat Jul 06, 2013 6:35 pm

Hi logi, well I just went out side and put my foot on the floor and she fired up with a spin over and sat idling with no light.
Throttle position sensor might be worth checking as now you mention it I have noticed it has become a little sticky under foot sometimes and not smooth.
I'm sure the coolant temp sensor would not cause it to cut out/stumble.
Worth more investigation I think.

streetboy
Chatterbox

Posts : 62
Join date : 2012-02-17

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by streetboy on Sat Jul 06, 2013 6:37 pm

oh and logi, where do I look for the sensor and what does it look like?
Cheers Mark.

streetboy
Chatterbox

Posts : 62
Join date : 2012-02-17

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by Logi on Sat Jul 06, 2013 6:51 pm

Dunno about yours? Mine's a 1300 and it's on the efi unit under the drivers seat.
avatar
Logi
Jet Warrior

Posts : 3603
Join date : 2011-04-07
Age : 82
Location : Kilmarnock

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by rich the mechanic on Sun Jul 07, 2013 10:50 am

The coolant sensor is on the back of the head just under the dizzy with a green plug it does cause start up issues as I had to replace ours after I broke it but it didn't cause any running issues since warm only coughed a bit till it was up to temp from cold and hot starting was a long time spinning it over while slowly pumping the throttle till it caught.
avatar
rich the mechanic
Jet Addict

Posts : 1824
Join date : 2010-01-03
Age : 37
Location : Essex

http://www.thread-bare.biz

Back to top Go down

Re: engine light flashed on and no start! help!!

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum