Piaggio Porter...labours!

Page 2 of 2 Previous  1, 2

View previous topic View next topic Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Sun Dec 15, 2013 5:42 pm

Nothing simple.

It sounds like some form of fuel starvation, I'm not sure if its caused by electronics or mechanics.

My next route of diagnostics would be to attach a pressure gauge to the fuel feed line and watch what happens, make sure we are not losing fuel feed pressure - as this is a pretty simple thing to test.
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Sun Dec 15, 2013 6:30 pm

Ok!
For this test, I have to go to a mechanic because I haven't a pressure gauge in my lab!
Where do I put this pressure gauge? Do I have to test it when the engine is cold and when it is warm as well?
Which average value must I find?
Thanks a lot

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Mon Dec 16, 2013 12:09 am

You just need to T in a pressure gauge into the fuel supply line, e.g. the fuel filter line before or after, or where the pipe from the fuel filter goes to the fuel rail feed on the engine.

Then run the van as normal, and when the power dies see if your fuel pressure is failing too.

If the pressure fails causing the engine to die, then you know the fault is somewhere in either the fuel pump and wiring, the fuel filter, or the fuel pressure regulator on the injector rail.

You could buy a gauge for £10 and a T piece, and some hose clips.


You might find that the fuel system is not at fault, but then you can look elsewhere, e.g. the ignition system - which is harder to test.
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Mon Dec 16, 2013 11:54 am

Hi!
Good day today! 16/17° outside!
After dismantling and putting back nearly everything, I started my van this monday morning and I let the engine become warm!
I've noticed that engine is coughing when the fan radiator starts!
The engine speed changes all the time when the fan is on, the engine coughs regularly then, as soon as it stops, the engine speed becomes normal again and the engine coughs less often.
Which elements the EFI deals with when the engine is warm and the fan is on?
Thanks

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Fri Dec 20, 2013 12:36 pm

Hi!
I have made the test on the fuel circuit with a gauge home-made!
When i turn the key, the value is max 2,8bars. When engine cranked the value is 2,2bars. After a few minutes: 2,05 at 2,15 when i push on the accelerator.
the value never gets under 2bars even if the engine is warm and it begins to cough! During the cough the fuel pressure does not change, 2,2bars!
??!
I have placed the gauge between fuel filter and the entry of the ramp of injectors (pipe sub-assy)

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Fri Dec 20, 2013 2:43 pm

Sounds promising.

That means your coughing isn't caused by a lack of fuel pressure.


Next....

Does your van have 2 coil packs, or 4?
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Fri Dec 20, 2013 5:19 pm

2 coil packs!
?
Thanks!

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Fri Dec 20, 2013 7:05 pm

I'm really not sure which way to point you now Sad

Can you post a photo of your cam position sensor here.

I want to see what angle it is at.

Someone might have put the cam belt on wrong.
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Mon Dec 23, 2013 9:51 am


huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Mon Dec 23, 2013 9:53 am


huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Mon Dec 23, 2013 9:54 am


huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Mon Dec 23, 2013 10:00 am

My van


huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Thu Dec 26, 2013 1:48 pm

Hi! Hope you had a nice Christmas!
What do you think of my pictures?
O

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by rich the mechanic on Thu Dec 26, 2013 5:24 pm

Merry xmas and happy new year.

The pictures are nice and clear.
avatar
rich the mechanic
Jet Addict

Posts : 1824
Join date : 2010-01-03
Age : 37
Location : Essex

http://www.thread-bare.biz

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Sun Dec 29, 2013 7:35 pm

Hi!
Thank you Rich the Mechanic!
Some Help?!!

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Tue Dec 31, 2013 12:12 am

Well the cam sensor looks like it is lined up correctly.

If someone puts the cam belt on wrong, often they setup the cam sensor to make it run better.

Hard to give you any more guidance really! Not very helpful I know, but its not a common fault issue it would seem.

Does the speedo/mph gauge work?
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Thu Jan 02, 2014 3:37 pm

Hi!
On this ignition wire... is it enough to make the trouble on my van?" />

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Thu Jan 02, 2014 4:06 pm

After half an hour runing... i think so!!!!

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Thu Jan 02, 2014 5:31 pm

People do have some issues with the plug leads.

Worth a try but don't hold your breath.
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Thu Jan 02, 2014 5:32 pm

If you cannot find a replacement I will have one somewhere I can send to you in France.
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Thu Jan 09, 2014 11:33 am

Hi!
Thanks a lot for your proposal!
I repaired as i could and until now it works! Fingers crossed!
Best for the new year and thanks for all!
 Very Happy 

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Thu Jan 09, 2014 3:16 pm

That is fantastic mate!
avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Fri Jan 17, 2014 8:17 am

Hi!
After all these adventures, my van took the compulsory equivalent of your MOT and...
they refused it because of a pollution trouble.
CO: 0.44%
Acc: 0.46%
Lamb: 1.044
The mechanics told me it's the catalyst's fault.
Do you know a website where I can find this part?
In France, the nearest retailer charges me 891.01 euros ex VAT.
He thinks I'm Rockfeller...
Have a nice day
Huchman

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Fri Jan 17, 2014 8:18 am

I forgot the reference
OEN: 17420-87521-000
if I'm not wrong

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by HighlyJetted on Fri Jan 17, 2014 8:49 am

avatar
HighlyJetted
Hijet Overdose

Posts : 5416
Join date : 2009-10-06
Age : 34
Location : Such a Dick

http://www.daihatsuhijet.co.uk

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Tue Jan 21, 2014 9:12 am



Hi!
I think on ebay there are only catalyst for hijet pick-up, for my van the model is 17420 87521 000 like this photo not 17420 87521 000!
I find this on microfiches!
The tube is shorter for a box van?!
I can buy the pick-up model but after i have to adapt it and use a weldind torch?

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by huchman on Thu Jan 23, 2014 7:14 pm

Hi!
I've taken down the catalytic converter of my van...
the reference daihatsu is 87527?!!
The length is 900mm!

huchman
Clubman

Posts : 38
Join date : 2013-01-22
Location : Saint-Martinien _ Auvergne _ France

Back to top Go down

Re: Piaggio Porter...labours!

Post by El_Ventu on Tue Mar 25, 2014 1:11 pm

Put on a universal one!
I put on mine a metallic one bought on ebay for less than 100€, I done the italian equivalent of MOT and all is ok,even with all the exhaust line hand made!
Cheers from italy!

El_Ventu
Centurion

Posts : 220
Join date : 2012-10-07

Back to top Go down

Re: Piaggio Porter...labours!

Post by Sponsored content


Sponsored content


Back to top Go down

Page 2 of 2 Previous  1, 2

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum