Hi jet 993 Thermostat fitted.

View previous topic View next topic Go down

Hi jet 993 Thermostat fitted.

Post by Balbarh on Sun Nov 21, 2010 9:56 pm

Well found out why having the problems with thermostat, my car didnt have one in, it had been removed and the fan wired to be on constantly. The thermostat is in, seems to be going ok, but I think needs flushing (friend advised). Am expecting problems as it must of overheated in the past for someone to remove the thermostat. Temperature guage went up to half way after driving about 10 mins, stopped at that for a while then cooled right down, could this be an airlock. Any tips would be much appreciated.
Balbarh

Balbarh
New Member
New Member

Posts : 2
Join date : 2010-11-19

Back to top Go down

Re: Hi jet 993 Thermostat fitted.

Post by PFM on Mon Nov 22, 2010 7:57 pm

Did you refill the cooling system exactly as per the instructions (i.e., remove rad cap and blanking cap, header rail cap, temp control to hot, fill until water comes out of header rail, refit header rail cap, fill radiator is full, refit rad cap and blanking cap)?

When temp gauge reads normal, is rad an even temperature from top to bottom?

PFM
Jet Addict

Posts : 1466
Join date : 2010-04-24
Age : 56
Location : East Sussex

Back to top Go down

Re: Hi jet 993 Thermostat fitted.

Post by rich the mechanic on Mon Nov 22, 2010 10:18 pm

ours does that the needle goes up and down like a yo yo and just after a fill it goes up a lot hotter than normal driving and the settles back to a yo yo between the lower cold mark and about the middle where the thermometer logo is.
avatar
rich the mechanic
Jet Addict

Posts : 1824
Join date : 2010-01-03
Age : 37
Location : Essex

http://www.thread-bare.biz

Back to top Go down

Re: Hi jet 993 Thermostat fitted.

Post by leopard_pagan on Tue Nov 23, 2010 7:28 pm

if in doubt on how to bleed the cooling system, my van 998 EFI has instructions under the front flap that gets you access to the radiator cap
avatar
leopard_pagan
Admin

Posts : 1105
Join date : 2009-09-21

Back to top Go down

Re: Hi jet 993 Thermostat fitted.

Post by PFM on Tue Nov 23, 2010 7:32 pm

rich the mechanic wrote:ours does that the needle goes up and down like a yo yo and just after a fill it goes up a lot hotter than normal driving and the settles back to a yo yo between the lower cold mark and about the middle where the thermometer logo is.

That's interesting - mine only does that when it's very low on water. Maybe your rad is partially blocked? I fitted an exchange rad and a new pressure cap to my S-reg 998 and it's been perfect ever since.

PFM
Jet Addict

Posts : 1466
Join date : 2010-04-24
Age : 56
Location : East Sussex

Back to top Go down

Re: Hi jet 993 Thermostat fitted.

Post by rich the mechanic on Wed Nov 24, 2010 8:21 pm

PFM wrote:That's interesting - mine only does that when it's very low on water. Maybe your rad is partially blocked? I fitted an exchange rad and a new pressure cap to my S-reg 998 and it's been perfect ever since.

I have had our rad off several times and repaired a couple of leaks it flows through fine it has had a problem on the fuel which was the MAP sensor and since I have changed it the fan switch in the rad has started working I cant see how its connected on the wiring diagram but where as before it was nearly always yoyoing now it does settle quicker it used to take 30 miles now it sorts in about 15 and then sits fairly steady.
avatar
rich the mechanic
Jet Addict

Posts : 1824
Join date : 2010-01-03
Age : 37
Location : Essex

http://www.thread-bare.biz

Back to top Go down

Re: Hi jet 993 Thermostat fitted.

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum