replaced clutch cable after it broke on a ride, now clutch isnt working

View previous topic View next topic Go down

replaced clutch cable after it broke on a ride, now clutch isnt working

Post by S65 U.P Mi. on Wed Oct 07, 2015 10:32 pm

Hello all, This is my first post and Im a new member. I just picked up a S65 hijet and everything was going good for the first week. While i was out for a ride my clutch cable broke, I just recieved my cable from japan and I installed it but I have no clutch, Is there something that could have come apart when the clutch cable snapped?
Thank you for any and all help.

S65 U.P Mi.
New Member
New Member

Posts : 3
Join date : 2015-10-07

Back to top Go down

Re: replaced clutch cable after it broke on a ride, now clutch isnt working

Post by Guest on Thu Oct 08, 2015 4:02 pm

If you crawl underneath, when you pull the clutch arm forward does it meet with resistance or is it flopping about inside?? There will be a little play up and down in the oblong access hole that you get to the arm through with the rubber cover over it.
If the whole arm moves back and forth pivoting on the clutch thrust race, then it could be the Clutch Operating Arm has become detached from its pivot point but it should be held in place by a shaped spring clip which I have seen break or become detached from the pivot point.
Another possibility is that the clutch release bearing has jammed due to wear and caused your cable to break in the first place. I haven't seen it happen on a Hi-Jet before but numerous occasions on other vehicles, both inline rear wheel drive and front wheel drive transverse gearboxes.
Most of the scenarios above are a gearbox out job which is a lot easier than it sounds. The worst bit is undoing all the bellhousing bolts. The rest is fairly simple but make sure you drain all the oil out from the lower plastic plug on the very end of the gearbox or when you drop the box onto your chest you will get Hypoid Gear Oil all over your jeans or leave the Propshaft in the end of the gearbox.

Guest
Guest


Back to top Go down

Re: replaced clutch cable after it broke on a ride, now clutch isnt working

Post by S65 U.P Mi. on Thu Oct 08, 2015 9:54 pm

Thank you, Ill have to take a better look at it this weekend.

S65 U.P Mi.
New Member
New Member

Posts : 3
Join date : 2015-10-07

Back to top Go down

Re: replaced clutch cable after it broke on a ride, now clutch isnt working

Post by S65 U.P Mi. on Sat Oct 10, 2015 2:16 pm

I took a quick look this morning , I unhooked the cable an moved the clutch arm back and forth, I hear a little thunk while moving the arm. could this be it is unhooked on the pivot ?

S65 U.P Mi.
New Member
New Member

Posts : 3
Join date : 2015-10-07

Back to top Go down

Re: replaced clutch cable after it broke on a ride, now clutch isnt working

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum