Small(?) electrical problem when starting

View previous topic View next topic Go down

Small(?) electrical problem when starting

Post by tornas on Tue Nov 01, 2016 8:18 am

Last week a small issue popped up when I tried starting the Hijet: the starter ran for a fraction of second before the power failed. A moment later the starter caught on and the engine started without problems. This all happened in one or two turns of the key.

I've experienced a similar 'hickup' once more but most of the times the Hijet starts without a problem.

There had been no rain the whole day when the problem occured so I don't think there is water in the electrical system. I'd like to find the cause of the problem but wouldn't know where to start. Any ideas?

tornas
Centurion

Posts : 189
Join date : 2016-03-07
Age : 34
Location : Amsterdam

Back to top Go down

Re: Small(?) electrical problem when starting

Post by wrightgeordie on Tue Nov 01, 2016 1:43 pm

Check all of your battery and starter motor connections, they all need to be clean, free of corrosion and tight. having good earth connections are particularly important.
avatar
wrightgeordie
Chatterbox

Posts : 67
Join date : 2015-12-27
Age : 63
Location : County Armagh

Back to top Go down

Re: Small(?) electrical problem when starting

Post by scotia on Fri Nov 04, 2016 8:07 am

had the same problem with the carry 2 weeks ago
battery died a week later.
its getting colder, if you have a dodgy battery it will fail these days
avatar
scotia
Cinquecento

Posts : 676
Join date : 2014-01-27
Age : 36
Location : twente

Back to top Go down

Re: Small(?) electrical problem when starting

Post by tornas on Fri Nov 04, 2016 8:42 am

Battery is less than a year old. I'll check all the connections Smile

tornas
Centurion

Posts : 189
Join date : 2016-03-07
Age : 34
Location : Amsterdam

Back to top Go down

Re: Small(?) electrical problem when starting

Post by PFM on Fri Nov 04, 2016 11:43 am

Could also be sign of sticking or worn brushes in the starter motor.

PFM
Jet Addict

Posts : 1449
Join date : 2010-04-24
Age : 56
Location : East Sussex

Back to top Go down

Re: Small(?) electrical problem when starting

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum