Stumped on overheat problem

View previous topic View next topic Go down

Stumped on overheat problem

Post by Scarface GTti on Sun Nov 13, 2016 9:07 pm

My truck was running hot so drained the coolant, flushed the system and replaced the thermostat. It sorted it. For 4000 miles or so it ran flawlessly. Then it started overheating badly, whenever it got close to the red I'd knock it off. Flushed it, bled it, checked thermostat etc, but it continued to do it. So I removed the head, stripped it, cleaned it, stuck it on the milling machine and clocked it up and it's only out 2 thou. So not warped. Today I pulled the water pump out and it looks brand new. The only other thing I can think is that the head is cracked? Any other thoughts?

Scarface GTti
Chatterbox

Posts : 92
Join date : 2014-12-02

Back to top Go down

Re: Stumped on overheat problem

Post by Raggy on Sun Nov 13, 2016 9:18 pm

Check any pipes for leaks where hoses join, only needs a fraction for air to get in. Is water being pushed out of the expansion tank or blowing out of rad? Is the seat of the fitting where the rad cap fits under the seat pitted and not sealing correctly? Have you got the correct antifreeze in it?
avatar
Raggy
Cinquecento

Posts : 986
Join date : 2015-05-25
Age : 54
Location : Doncaster

Back to top Go down

Re: Stumped on overheat problem

Post by Scarface GTti on Sun Nov 13, 2016 10:12 pm

It pressurises the expansion tank. Rad caps were replaced when I did the thermostat and the seats were spot on. I used the correct anti freeze

Scarface GTti
Chatterbox

Posts : 92
Join date : 2014-12-02

Back to top Go down

Re: Stumped on overheat problem

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum