over fueling??

View previous topic View next topic Go down

over fueling??

Post by Dalcoo on Wed Jul 12, 2017 9:33 pm

Hi

My father owns a 1.3 efi truck, thats had a romahome fitted, recently its been in the Garage to have a new water pump and a new thermostat housing fitted. on collection, although it ticks over and starts perfectly, it has no pull..... its feels like my old mini used to when you left the choke out when it was hot.... if you back off the throttle slightly it will very slowly pick up..... its been suggested that the timings out or that a temp sensor might be disconnected.... the mechanic that did the original work insists that if the timing was out it wouldn't tick over and rev so smoothly.

I'm grateful for any ideas you guys can assist with

thanks

Dalcoo
New Member
New Member

Posts : 2
Join date : 2017-07-12

Back to top Go down

Re: over fueling??

Post by PFM on Wed Jul 12, 2017 10:00 pm

Welcome. Did it pull OK before garage visit?

PFM
Jet Addict

Posts : 1468
Join date : 2010-04-24
Age : 57
Location : East Sussex

Back to top Go down

Re: over fueling??

Post by Dalcoo on Wed Jul 12, 2017 11:43 pm

yep absolutely fine

Dalcoo
New Member
New Member

Posts : 2
Join date : 2017-07-12

Back to top Go down

Re: over fueling??

Post by PFM on Thu Jul 13, 2017 12:18 am

Therefore, it must be related to what they did. Not 100%, but think water pump change means timing belt off. My guess, 1 tooth out but others may know better.

PFM
Jet Addict

Posts : 1468
Join date : 2010-04-24
Age : 57
Location : East Sussex

Back to top Go down

Re: over fueling??

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum